Investigating Performance on Brand and Brand Sets Tabs

Incident Report for ListenFirst

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 11:36 EDT

Investigating

We are currently investigating reports of performance issues affecting parts of the platform. Some users may have difficulty accessing certain features, such as Brand > Content or Brand Sets > Rankings. Our team is actively working to identify the root cause and will provide an update as soon as more information becomes available.
Posted Jul 10, 2026 - 08:31 EDT
This incident affected: Application.