Platform Currently Unavailable

Incident Report for ListenFirst

Resolved

We are back up and running! The issue affecting the platform has been resolved. Thanks for bearing with us. If you notice anything out of the ordinary, please don't hesitate to reach out to our support team.
Posted Jun 09, 2026 - 09:22 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 09, 2026 - 09:17 EDT

Identified

We're experiencing an unplanned outage affecting platform access. Our team has identified the issue and is actively working to restore service. We apologize for the disruption and will provide an update at ~12 pm ET. Thank you for your patience.
Posted Jun 09, 2026 - 09:17 EDT
This incident affected: Application.