Application & APIs are down temporarily from 11:00 PM EST

Incident Report for ListenFirst

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 02:10 EST

Update

Issue resolved. System & APIs are working as expected.
Posted Feb 27, 2026 - 02:08 EST

Investigating

We are looking into the issue on priority and will keep you posted.
Posted Feb 27, 2026 - 01:25 EST
This incident affected: Application, Platform API, Data Exports, Data Systems & Analytics, and Authentication System.