Exports and Reports Delay

Incident Report for ListenFirst

Resolved

This incident has been resolved.
Posted 2 months ago. Apr 08, 2025 - 13:47 EDT

Update

Exports and Data Studio reports are performing slower than expected. We are looking into this and will provide an update shortly.
Posted 2 months ago. Apr 08, 2025 - 08:36 EDT

Identified

Exports and reports are performing slower than expected. We are looking into this and will provide an update shortly.
Posted 2 months ago. Apr 08, 2025 - 08:07 EDT
This incident affected: Data Exports.