AWS Outage

Incident Report for ListenFirst

Resolved

AWS service has been restored.
Posted Oct 21, 2025 - 06:38 EDT

Investigating

Due to a widespread AWS outage, platform data within ListenFirst will be delayed. Our team is closely monitoring the situation and working to restore full functionality as soon as possible.
Posted Oct 20, 2025 - 09:38 EDT
This incident affected: Application, Platform API, Data Exports, Data Systems & Analytics, Authentication System, Audience, Listening Service, and Help and Training Systems.