Brand Content Filtering Issue

Incident Report for ListenFirst

Identified

We have implemented a partial fix for this issue. Brand Content filtering should now return results as expected.

There is still an outstanding issue impacting Roll-Up brands only. While the post table and export data are accurate, the post volume and the aggregate table displayed on screen may differ.

A full fix is currently in testing and will be live shortly. In the meantime, for the most accurate post volume for Roll-Up brands, please refer to the export.
Posted Jun 25, 2026 - 10:45 EDT

Investigating

There is currently an issue affecting the platform when users apply filters in the Brand > Content screen. Engineering are aware of this issue and are working on a fix.
Posted Jun 24, 2026 - 12:52 EDT
This incident affects: Application.