Instagram Reels Insights Outage

Incident Report for ListenFirst

Identified

We have implemented a fix for the ongoing issue and expect it to be live by EOD.

No action is required: The update will be applied automatically on our end.
Service restoration: Normal functionality should return as soon as the deployment is complete.
Posted Jun 03, 2026 - 10:59 EDT

Investigating

We are investigating an outage impacting Instagram Reels Insights data for some posts published on or after 5/28. We are actively working to restore service.
Posted Jun 02, 2026 - 11:58 EDT
This incident affects: Application and Social Channels (Instagram).