Data for 3/31/2026 is delayed

Incident Report for ListenFirst

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 11:03 EDT

Monitoring

We experienced an unexpected systems error overnight that has caused a delay in our data processing pipeline. The root cause has been resolved and processing is proceeding as normal. However, data availability for yesterday is delayed until ~12:00 ET.

Outside of the delay, no other impact to data is anticipated.
Posted Apr 01, 2026 - 08:08 EDT
This incident affected: Data Systems & Analytics.