Static Facebook Posts not Returning Data as of 2/27

Incident Report for ListenFirst

Update

We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 12:31 EDT

Identified

Facebook Post data for high-volume accounts is currently unavailable. We are investigating this issue and hope for a resolution soon. This is evident in both the platform and the API."
Posted Mar 10, 2026 - 11:40 EDT
This incident affects: Social Channels (Facebook) and Application, Platform API.